For BS5837 surveys, Arboricultural Consultants are often required to deal with CAD. OTISS supports you in various ways to get the job done quickly and easily.

Why do I need to use CAD?

You may ask “Why do I need to use CAD for the detailed Tree Protection Plans?”, let us explain why.

  • Arboricultural consultants often work with architects who provide the site/topo drawings in CAD format. OTISS users can load these drawings and use them as a base-layer on which to plot the trees. Use OTISS for the on-site surveying to collect all the required data and photos. OTISS can then generate all the required spatial data for RPA, crown, shadow etc as a CAD/DXF file that can be sent back to the architects. The architects’ CAD technicians will merge this survey data with the architectural drawings, and they have the CAD expertise to produce the required drawings.
  • CAD applications are designed to do this work; i.e. laying out drawings in minute detail, total control over all aspects of colour, line thickness, font, text placement, etc. And these applications have been developed and improved over decades.
  • Any tools that we could produce (or our competitors, or most drawing packages) will always fall short and compare extremely badly with CAD applications.
  • But unfortunately, they don’t make CAD applications that are easy and intuitive. Its another skill to learn!
  • So it seems to be accepted practice to use survey tools to collect the data and then CAD for detailed modifications of the maps.
  • OTISS is excellent for data collection, and excel data reports, but for the protection plans, we cannot replace CAD.

Option 1: Starting with a CAD drawing

Arboricultural Consultants are often provided with architectual CAD drawings as their site/topo plan. While surveying you can plot trees directly onto this base drawing. After surveying, OTISS can generate a DXF file containing the tree icons, RPA and shadow arcs (see below), which can be easily merged with the original CAD drawing.

Step 1: OTISS allows you to directly import CAD drawings. The drawing can then be used like any other uploaded map or site plan – you can pan/zoom around the map and plot trees onto the drawing. See Loading Maps & Plans for full details.

Step 2: Use the OTISS mobile survey apps and the CAD drawing to plot the trees and gather the BS5837 survey data. If the drawing has used the national grid co-ordinates, then you can also use GPS and also use the online maps and aerial images.

Step 3: Goto the BS3837 spreadsheet page and use the Site and Survey filters to select what trees are required. The Reports-> CAD Data-> DXF format menu is used to generate a DXF file containing the tree icons, RPA and shadow arcs (see below). On the report CAD/DXF dialog:

  • Select the ‘Drawing unit’ for the DWG drawing that was loaded in step 1: metre or milli-metre.
  • Set the ‘Text Format’ to show the information you want to appear with each tree/group – click on the examples provided to see the options.
  • Press Download DXF buton to generate the DXF file and save it to disk.

This DXF file can now be merged with the original CAD drawing using your own CAD application (step 4), or can be sent directly to the architects and let them do it.

These next steps are intended to be used by people who have their own CAD application and are able to manipulate the drawing objects to produce the set of Survey Plans and Tree Protection Plans to suit their requirements.

Step 4: To combine the trees and the site plan, you need to open the original drawing (using your CAD application) and use the appropriate command to ‘import’ or ‘merge’ the DXF file that you saved in step 3. The co-ordinate system in both drawings should be the same, so you should specify 0,0 as the ‘origin’ or ‘grid point’. Save this merged file under a new name.

Step 5: The CAD drawing how has an extra set of layers that contain all the tree objects – see below for a description of each layer. For each type of Survey Plan and Tree Protection Plan that you wish to produce, you will need to show/hide the appropriate layers and use the CAD features to make any other required changes. For example:

  • Show/hide the RPA, shadow layers you require.
  • Select a layer and change the colour and line styles. This will change all the items in that layer in one operation.
  • Select specific objects or select all the items in a single layer, then they can all be manipulated as required – e.g. change text font or size.
  • Customise and create offset RPAs as required for some of the trees (i.e. the yellow lines on the RPA_Polygon layer).

Option 2: Using a PDF site plan to produce CAD reports…

Arboricultural Consultants often use PDFs or OS maps for their surveys, but they want to be able to produce CAD layouts and printouts for their BS5837 reports. After surveying, OTISS can generate a DXF file containing the tree icons, RPA and shadow arcs (see below), and this file can also include the image of the site plan. So, even though you did not start with a CAD site plan, you can use your CAD application to produce more sophisticated printouts.

Step 1: Load the PDF, map or site/topo plan as normal – see Loading Maps & Plans for details.

Step 2: Use the OTISS mobile survey apps to plot the trees and gather the BS5837 survey data. If the site plan can be geo-referenced to use the national grid co-ordinates, then you can also use GPS and also use the online maps and aerial images. See Loading Maps & Plans for more explanation about geo-referencing.

Step 3: Goto the BS3837 spreadsheet page and use the Site and Survey filters to select what trees are required. The Reports-> CAD Data-> DXF format menu is used to generate a DXF file containing the tree icons, RPA and shadow arcs (see below). On the report CAD/DXF dialog:

  • Be sure to tick the ‘Include image’ check box.
  • Set the ‘Text Format’ to show the information you want to appear with each tree/group – click on the examples provided to see the options.
  • Press Download DXF buton to download both a DXF file and a TIF image file.

The DXF file has all the tree data, and TIF file is an image of the original PDF (with no tree data). Place both the DXF file and the TIF file in the same folder on your computer. NB: The image file’s name must be as shown on the OTISS dialog – this name is stored in the DXF file – you may have to remove and “(x)” suffix that may have been added in the download process.

These next steps are intended to be used by people who have their own CAD application and are able to manipulate the drawing objects to produce the set of Survey Plans and Tree Protection Plans to suit their requirements.

Step 4: Use you CAD application to open the DXF file. You will see a TIF image with the trees icons on top. The image is not stored inside the DXF file – it must be stored in a separate image file in the same folder. In AutoCAD (and most CAD applications), it seems to work best if you first load the DXF file, then Save it in the DWG format and close the file. This is because the OTISS generated DXF files contain the bare minimum of information, and may not be suitable as a ‘base’ file for complex drawings in all CAD products. When you open the DXF drawing in some CAD applications, you may have to use the ‘Extents’ or ‘Fit to window’ command to locate the trees.

Step 5: The CAD drawing how has an extra set of layers that contain all the tree objects – see below for a description of each layer. For each type of Survey Plan and Tree Protection Plan that you wish to produce, you will need to show/hide the appropriate layers and use the CAD features to make any other required changes. For example

  • Show/hide the RPA, shadow layers you require.
  • Select a layer and change the colour and line styles. This will change all the items in that layer in one operation.
  • Select specific objects or select all the items in a single layer, then they can all be manipulated as required – e.g. change text font or size.
  • Customise and create offset RPAs as required for some of the trees (i.e. the yellow lines on the RPA_Polygon layer).

Troubleshooting…

  • When you open the DXF drawing in some CAD applications, you may have to use the ‘Extents’ or ‘Fit to window’ command to locate the trees.
  • If you have included the site plan image in the DXF file:-
    • The actual image is not stored within the DXF file itself, it is stored as a separate image file (usually with the .tif file extension), and is referenced from the DXF file. The image should appear as a background to the trees.
    • The site plan image MUST be stored in the same folder as the DXF file.
    • Make sure the site plan image filename is correct as shown on the Download dialog – i.e. sometimes extra letters such as ‘(n)’ are appended to the filename during the download process.
    • Some CAD applications don’t like the uncompressed images that we use on OTISS, and the site plan image does not appear as a background when you open the DXF file. This can easily be fixed as follows. (1) Open the Microsoft Paint application (or your favourite image editor), then use it to open the image file. (2) Don’t do anything – just but press the Save button and then exit the Paint application – this should re-compress the image file. (3) Now try opening the DXF file again – it usually works fine now.

Option 3: Using OTISS with KeyTREE

Many arboriculturalists and architects use the KeyTREE utility for plotting tree survey data onto AutoCAD drawings. OTISS is an excellant data collection system that can be used on-site to gather and collate the survey data. OTISS can then generate a KML formatted file that can be imported into KeyTREE. This makes it seamless to use OTISS for BS5837 data collection and KeyTREE for preparing your CAD drawings.

We work closely with the KeyTREE development team to make sure that all the information collected in OTISS can be easily and quickly transfered into KeyTREE drawings.

Step 1: OTISS allows you to directly import CAD drawings. The drawing can then be used like any other uploaded map or site plan – you can pan/zoom around the map and plot trees onto the drawing. See Loading Maps & Plans for full details. If the CAD drawings uses the national grid co-ordinates, then you can also use GPS and also overlay the drawing on the online maps and aerial images.

Step 2: Customise the BS5837 survey. All the standard BS5837 fields (category, height, canopy NESW, numStems, stemDiameters, lifeStage, lifeExpectancy, crownClearance, lowestBranch, etc.) should be used and will be exported to KeyTREE. In addition, please setup the following fields.

OTISS Field
Name (KeyTREE)
customText1Physiological Condition
customText2Structural Condition

Step 3: Use the OTISS BS5837 Survey app to plot the trees and gather the BS5837 survey data. Sync the data to the OTISS website, and check the data using the OTISS maps and spreadsheet pages.

Step 4: Goto the BS3837 spreadsheet page and use the Site and Survey filters to select what trees are required. Use the Reports-> CAD Data-> KeyTREE (kml) menu to generate a kml import file for KeyTREE.

  • All the above BS5837 data (both measured and estimated values) will be included in the kml file, as will the tree location points and the polygon shapes for trees and hedges.
  • OTISS does not collect information about (a) root spread or (b) 8-point canopies. If required, this information would have to be collected separately and inputted to KeyTREE in Step 6 below.

Step 5: Startup AutoCAD with KeyTREE, open up the DWG drawing, and press the KeyTREE> KeyTREE Import button. Simply locate the OTISS generated KML file and import all the collected survey data. The trees will automatically be added to your drawing.

Step 6: Use all the KeyTREE features to produce a range of layouts and plans.

Option 4: Using OTISS with ArborCAD

We know that many arboriculturalists have bought and use the ArborCAD utility for plotting tree survey data onto AutoCAD drawings. OTISS provides a Report option to download an Excel spreadsheet that is compatible with the ArborCAD system. This makes it seamless to use OTISS for BS5837 data collection and ArborCad for preparing your CAD drawings.

Step 1: OTISS allows you to directly import CAD drawings. The drawing can then be used like any other uploaded map or site plan – you can pan/zoom around the map and plot trees onto the drawing. See Loading Maps & Plans for full details.

Step 2: Use the OTISS BS5837 Survey app to plot the trees and gather the BS5837 survey data. If the site plan can be geo-referenced to use the national grid co-ordinates, then you can also use GPS and also use the online maps and aerial images. See Loading Maps & Plans for more explanation about geo-referencing.

Step 3: Goto the BS3837 spreadsheet page and use the Site and Survey filters to select what trees are required. Use the Reports-> CAD Data-> ArborCAD Excel menu to generate an Excel spreadsheet for ArborCAD.

Step 4: Next you will need to setup an ArborCAD Filter. Full details are provided in the ArborCAD Help File Creating an ArborCAD filter from Excel on the ArborCAD website. You only have to setup the filter once. Save this filter for use on all the OTISS surveys.

Step 5: To import the OTISS data into ArborCAD, simply open the OTISS data spreadsheet using Excel and copy all the data to the clipboard. Then use the ArborCAD File-> “Import and Convert Survey Data from Clipboard” menu option to import the data. Its all explained in the above Help File!

OTISS Tree Protection Plan layers

In options 1 and 2 above, OTISS generates a DXF file with a set of layers that contain all the tree objects. For each type of Survey Plan and Tree Protection Plan that you wish to produce, you will need to show/hide the appropriate layers for asymmetric crown radius, RPA, shadows, etc.. It is also expected that you will use the CAD features (as required) to: carry out detailed changes to the RPA; add extra details for protective fences and ground cover; adjust text/label positions to improve clarity; etc.

Here are some examples.

  • The asymmetric crown is drawn based on the N,E,S,W radius. The colour corresponds to the BS5837 retention category.
  • The RPA is provided both as a grey circle and a shaded grey disc (just hide the one you don’t want). Another representation of the RPA is as an adjustable 12 sided polygon (yellow) – this is more useful when you want to offset the RPA or specify a detailed layout.
  • A Shadow is provided both as an outline arc and as a shaded grey arc (just hide the one you don’t want). If you have included a mature/ultimate height value, a further outline (dashed line) arc is shown.
  • The multi-line text block is configurable to include text and data from the survey data. It is configured in the Download DXF dialog panel and can include various data fields. The dialog provides some example layouts. Data fields are denoted by the fieldId within curly brackets.
  • Each tree is plotted using simple XY co-ordinates (metres) for site plans, or the Grid Reference coordinates for maps. For example, an item at location ‘TL 05635 04970’ will be plotted at x=505635 y=204970.
  • In all cases, the line colour, line thickness and visibility for all the trees in a specific retention category can be changed using the layer’s properties.
DXF LayerDescription
Site Plan LayerThis layer contains the image of the site plan or map that was loaded into OTISS. The image is not stored inside the DXF file – it is stored in a separate image file in the same folder.
Tree_LocationThis layer contains the small circles that represent the tree trunk. The colour corresponds to the BS5837 retention category.
Tree_CrownSpreadThis layer contains a asymmetric circle to represent crown spread using the N, E, S, W measurements. The colour corresponds to the BS5837 retention category. For tree groups and hedges, a polygon is drawn the same size as the plotted group.
Tree_ReferenceThis layer contains each tree’s reference number and is plotted beside the tree using the TreeText text style. The colour corresponds to the BS5837 retention category. The text font and height can be changed using the TreeText style properties.
Tree_TextThis layer contains a tailored set of text and information about each tree. It is configured in the Download DXF dialog panel and can include various data fields, e.g. tree’s reference number and the BS5837 retention category. This multi-lined text is plotted beside the tree using the TreeText text style. The colour corresponds to the BS5837 retention category. The text font and height can be changed using the TreeText style properties.
Tree_RPA_OutlineThis layer contains a grey circle representing the calculated RPA. For tree groups and hedges, a polygon is drawn the same size as the plotted group.
Tree_RPA_HatchThis layer contains a shaded, hatched, grey disc representing the calculated RPA. For tree groups and hedges, a polygon is drawn the same size as the plotted group.
Tree_RPA_Polygon
This layer contains a 12 sided polygon representing the calculated RPA. For tree groups and hedges, a polygon is drawn the same size as the plotted group. You can adjust the polygon to show the desired root protection fencing or to show an offset RPA.
Tree_First_BranchThis layer contains a red arrow representing the direction of the first/lowest branch.
Tree_Shadow_Outline_(current) This layer contains an outline arc representing the typcial shadow pattern based on the current tree height – i.e. an arc from NW to E using the tree height as radius. For tree groups and hedges, a polygon is drawn the same size as the plotted group.
Tree_Shadow_Hatch_(current) This layer contains a shaded, grey hatched arc representing the typcial shadow pattern. For tree groups and hedges, a polygon is drawn the same size as the plotted group.
Tree_Shadow_Outline_(future) This layer contains an outline arc (dashed line) representing the typcial shadow pattern based on the future mature/ultimate tree height.
TreeText StyleThis text style is used for both the Reference and tailored text. The text font and height can be changed using this text style’s properties. In some CAD applications, you may need to re-apply the text style to the text items to make the change – please consult your application’s reference manuals.

Some Background – CAD file formats

There are a number of CAD file formats, but the DXF format is the one we use within OTISS. The following definitions are from Wikipedia.

AutoCAD DXF (Drawing Interchange Format, or Drawing Exchange Format) is a CAD data file format developed by Autodesk for enabling data interoperability between AutoCAD and other programs. Autodesk now publishes the DXF specifications on its website for versions of DXF dating from AutoCAD Release 13.

DWG (“drawing”) is a binary file format used for storing two and three dimensional design data and metadata. It is the native format for several CAD packages including AutoCAD, IntelliCAD (and its variants) and Caddie. In addition, DWG is supported non-natively by many other CAD applications. The .bak (drawing backup), .dws (drawing standards), .dwt (drawing template) and .sv$ (temporary automatic save) files are also DWG files.

What this means in practice is that; (a) the DWG format is owned by AutoDesk, it can only be used under license, and is not compatible with all CAD products, whereas most products use DXF to exchange CAD drawings between different CAD products (including AutoCAD) – so we generate DXF files for the surveyed trees.

DWG TrueView is a free and very powerful CAD ‘viewer’ application provided by AutoDesk (the makers of AutoCAD). It allows you to read the OTISS DXF file, to change the colours and lineweights of the layers, and to generate plots.